Firmware-PCConfig Decode

Forum dedicated to discussion on EF Johnson Radio products

Moderator: willbartlett

User avatar
Intrinsically Safe
Posts: 344
Joined: Sat Oct 13, 2007 9:19 pm

Re: Firmware-PCConfig Decode

Post by Intrinsically Safe » Tue Jun 15, 2010 3:19 pm

bezking wrote:Thanks, except mine is 1.24.0.8, not 1.28.0.8 :grin:
DOH!!

PCC 1.24.0.8
1.14.3
2.4.6
3.4.6
Sean Penn: Last year I went to Iraq. Before Team America showed up, it was a happy place. They had flowery meadows and rainbow skies, and rivers made of chocolate, where the children danced and laughed and played with gumdrop smiles.

ve7ked
Posts: 3
Joined: Sun Mar 28, 2010 5:25 pm

Re: Firmware-PCConfig Decode

Post by ve7ked » Fri Jul 30, 2010 5:22 pm

Hello I have a EFJ 5100 with the following specs:

Model : 242-5117-660GS4

I have two copies of PCConfigure at my disposal, PCC 2.6.11 and 2.8.2.

That being said, I have read this radio and determined that it has the following Version Information and therefore is not compatible with the PCC that I have:

File Format Version : 5.8
DSP Software Version : 4.4.1
Controller Version : 4.4.4
Boot Load Version : 4.2
SEM Version : 3.4

I am curious which PCC I will currently need to program this radio.

I am also looking to find out what PCC / Firmware I am able to upgrade to so that I have the latest and greatest in bug fixes, ect.

Any help that you are able to provide would be appreciated. I have had this radio for a while, however the reciever was dead. Thanks to the info posted on the Version 4 VHF boards by Will Bartlett, I now have a fully functional transceiver. Thanks for the invaluable help to the community Will !

Thanks in advance,

Mike, VE7KED

User avatar
Intrinsically Safe
Posts: 344
Joined: Sat Oct 13, 2007 9:19 pm

Re: Firmware-PCConfig Decode

Post by Intrinsically Safe » Sun Aug 15, 2010 9:19 am

Hey mike.

You will need PCC 1.28.0.8 for that radio
the latest release is 4.14.5 which would require PCC 2.10.2.
Sean Penn: Last year I went to Iraq. Before Team America showed up, it was a happy place. They had flowery meadows and rainbow skies, and rivers made of chocolate, where the children danced and laughed and played with gumdrop smiles.

KD8FJI
Posts: 7
Joined: Thu Oct 07, 2010 7:18 am

Re: Firmware-PCConfig Decode

Post by KD8FJI » Thu Oct 07, 2010 6:04 pm

What PCC is needed for firmware 1.18.8?

Torchwood
Posts: 2
Joined: Thu Oct 07, 2010 7:17 pm

Re: Firmware-PCConfig Decode

Post by Torchwood » Thu Oct 07, 2010 7:26 pm

What PCC is needed for this EFJ 5100?

File Format ver. 5.9
DSP Software ver. 4.8.2
Controller ver 4.8.12
Boot load ver 4.3
SEM ver 3.4

mc shaggy
Posts: 1
Joined: Sat Sep 03, 2011 3:29 am

Re: Firmware-PCConfig Decode

Post by mc shaggy » Sat Sep 03, 2011 3:35 am

i need the update for my vhf radio to do p25 trunking any help

jd01
Posts: 3
Joined: Fri Feb 24, 2012 2:10 pm

Re: Firmware-PCConfig Decode

Post by jd01 » Fri Feb 24, 2012 2:31 pm

Can someone tell me what version of pcc I need for a 5100 v4.10.11? Also, is this still available from EFJ?

Thanks in advance for your help.

QuarterWave
Posts: 6
Joined: Fri Jan 09, 2009 3:17 pm

Re: Firmware-PCConfig Decode

Post by QuarterWave » Fri Feb 24, 2012 5:05 pm

jd01 wrote:Can someone tell me what version of pcc I need for a 5100 v4.10.11? Also, is this still available from EFJ?

Thanks in advance for your help.
PC Configure 2.6.11 is what you want.
Contact EFJ customer service and ask for a price quote.
While you're talking to them about PCC ask how much a copy of the new firmware (4.14.5) would cost you.

User avatar
Intrinsically Safe
Posts: 344
Joined: Sat Oct 13, 2007 9:19 pm

Re: Firmware-PCConfig Decode

Post by Intrinsically Safe » Mon Feb 27, 2012 11:10 pm

Just to clear some of the confusion up on decoding PCConfig version needed..

For ES Products (5100 and 5300), the radio firmware will be in the format of 6.xx.yy
The version of PCC you will need will be 2 versions higher of the xx number.
For example, if you have a radio with 6.10.5, you will need 2.12.y PCC to program it.
As for the latest release 6.16.y, you will need PCC 2.18.y to program

For X platform radios (4.xx.yy) it is not as simple and you need a secret decoder ring most of the time :stupid:

Hope this helps a little bit.

I.S.
Sean Penn: Last year I went to Iraq. Before Team America showed up, it was a happy place. They had flowery meadows and rainbow skies, and rivers made of chocolate, where the children danced and laughed and played with gumdrop smiles.

jcemt911
Posts: 6
Joined: Tue Mar 27, 2012 1:57 am

Re: Firmware-PCConfig Decode

Post by jcemt911 » Tue Apr 03, 2012 2:21 am

What PCC would I need for firmware version 4.14.5?

Thanks,

Jared

jhjonesjr
Posts: 2
Joined: Wed Apr 18, 2012 2:06 pm

Re: Firmware-PCConfig Decode

Post by jhjonesjr » Fri Apr 20, 2012 9:20 pm

I also need to know what PCC version is needed to program the 51SL with versions 4.14.5 and 4.8.12?

jcemt911
Posts: 6
Joined: Tue Mar 27, 2012 1:57 am

Re: Firmware-PCConfig Decode

Post by jcemt911 » Tue May 22, 2012 4:12 am

jhjonesjr wrote:I also need to know what PCC version is needed to program the 51SL with versions 4.14.5 and 4.8.12?
4.14.5 uses PCC 2.10.2

jcemt911
Posts: 6
Joined: Tue Mar 27, 2012 1:57 am

Re: Firmware-PCConfig Decode

Post by jcemt911 » Tue May 22, 2012 1:03 pm

jhjonesjr wrote:I also need to know what PCC version is needed to program the 51SL with versions 4.14.5 and 4.8.12?
Just confirmed that 4.8.12 uses PCC 2.10.2 also.

emt.micah
Posts: 5
Joined: Wed May 23, 2012 10:55 pm

Re: Firmware-PCConfig Decode

Post by emt.micah » Thu Jul 12, 2012 8:59 pm

Dang these EFJ's are confusing.

From the model number decode thread I have:

Model 242-5318-201-AAAB
5300 Not SL/Ascend
VHF
Remote Mount
P25 Conv/Ana
No Encryption
Standard Head

I get the following numbers when I turn it on: Versions 3.17.21 and 1.26.3.

This is one of our spares at work. Several of the others from this same purchase batch were re-programmed while I was gone for the National Guard. Whoever programed them must have had their own software, cause none of mine works. I need to program this one and get it programmed digital like the others.

Which version if PCC do I need?

And I.S, thanks in advance. You've helped a ton of people with the EFJs. We appreciate it.

User avatar
Intrinsically Safe
Posts: 344
Joined: Sat Oct 13, 2007 9:19 pm

Re: Firmware-PCConfig Decode

Post by Intrinsically Safe » Thu Jul 12, 2012 10:42 pm

3.17.21 is the code version of the control head.
1.26.3 is the ARM code (main firmware) there is a separate DSP version for that radio as well but since you are not upgrading we don't need to worry about that.
You would need PCC 1.24.0.0 as that is the sanctioned version.

However if it was programmed with a higher version it may have screwed up the file formatting, which can be a pain in the arse to try and figure out how high they went.

I.S.
Sean Penn: Last year I went to Iraq. Before Team America showed up, it was a happy place. They had flowery meadows and rainbow skies, and rivers made of chocolate, where the children danced and laughed and played with gumdrop smiles.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest