EFJ 5100 Mic connection issues

Forum dedicated to discussion on EF Johnson Radio products

Moderator: willbartlett

Post Reply
GreenFire
Posts: 1
Joined: Wed May 20, 2015 7:31 pm

EFJ 5100 Mic connection issues

Post by GreenFire » Wed May 20, 2015 7:46 pm

Bought a used EFJ 5100 off of a good friend about 3 weeks ago, and have since bought a brand new EFJ Mic (589-0015-057) that worked great up until today. After trying to transmit, Mic sound was very weak and scratchy, so I unplugged Mic and built-in sound worked fine. After reconnecting and still finding sound bad, I pushed up and against the radio and the sound worked fine. I believe that there is a problem somewhere between the connections of the Mic and the ports of the radio itself... any advice or similar problems?

*Hope pictures help... Can give different angles if needed*



Image

Image

If anyone has anything that can help... Please let me know.

Thanks.

User avatar
Intrinsically Safe
Posts: 344
Joined: Sat Oct 13, 2007 9:19 pm

Re: EFJ 5100 Mic connection issues

Post by Intrinsically Safe » Wed Jun 03, 2015 1:20 pm

This looks an older version radio (pre ES) and the side connectors were notoriously soft. You can see the dimpling taking place.
That is the crux of your problems, poor electrical/mechanical connection.
The only way to remedy is to press the connector tighter somehow, or replace the side port flex.

I.S.
Sean Penn: Last year I went to Iraq. Before Team America showed up, it was a happy place. They had flowery meadows and rainbow skies, and rivers made of chocolate, where the children danced and laughed and played with gumdrop smiles.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests