Page 1 of 1


Posted: Mon Oct 09, 2017 12:34 pm
by W0VNE
I refurb old EF johnsons (Clean, test, repair, tune) and have some ver 1 5100's I've been looking at them and one has this odd problem where is comes up really slow and after self test reports BLANK. Then after a short time it says NO PROGRAM. Now, I'm still a bit of a noob but I think this is that the radio lacks firmware? It reports ver 1.20.11 on power up (Yes, I know that sounds weird because I've seen that there is supposed to be a version 1.18.x thats the "final" version. But I have a number of these and they work great. Any ideals on how to get this one running? I ppreciate any ideas.

And second issue. I've tried sending money to a guy on Ebay and I've tried getting it from here but I just can't seem to find anything that will update a 5100 from 1.6.x or 1.8.x to 1.18 The 1.18.x updater routine I have is a stand alone program not the older .hex files etc that you would use PCC to update with. And I've powered up read the version then restarted so its in code download mode (Bottom button) It starts unpacking the files then nothing. Just communications errors which is odd since it just worked telling me the version. Has anyone got any advise on how to make that work?

Last question. I've (At last) got the ver 1 5300 firmware express updater for making old radios into 1.30.11 version (Old radios) *Thank you AUSTECH! It seems like this works if the previous version is newer then 1.10.x (Or I'm doing something wrong) I've got a little circuit thats switch selectable to do standard programing or put it into firmware upload mode. Has anyone got something between 1.10.x and 1.30.11 that I can try? The 1.10.x firmware is craptastic.

Thanks - Jay at Refurbatron
or the letter "j" period "craswell at GEE male dot commies.


Posted: Mon Jan 15, 2018 10:44 pm
by W0VNE
I said I was a bit of a noob. This is incorrect. I am a total zeroid. "NO PROGRAM" is an indication that the radio doesn't have any channels programmed. So... If you load any code plug into the radio that error message goes away.

Duh! Sorry to waste peoples time.

- Jay