Midland Olympian mic question

Forum dedicated to discussion on Midland Radio products. (Questions/Instructions about modifing CB radios are prohibited)
Post Reply
jrm5265
Posts: 23
Joined: Sat Dec 13, 2003 6:13 pm
Location: Covington Ga

Midland Olympian mic question

Post by jrm5265 » Wed Nov 22, 2006 2:31 pm

hey guys I have 2 Olympian VHF mobiles and both are doing the same thing.........when you unkey the person your talking to hears what sounds like a metallic clank at end of your tranmission does it on everything Ive got programmed in them so its not ONE repeater etc that its doing it on. Im thinking theres something Ive got set wrong in the programming but Im scared to start changing stuff anybody got an idea what in the programming (ie reverse burst or some kinda mic setting that if set wrong would cause that. Radio sounds good its just that sound at end of transmission thats annoying and sound like metallic clank...........any of you Midlandnites have any ideas?

Thanks
Joe Mobley
East Metro Drug Enforcement
Covington Ga

Elighting
Posts: 54
Joined: Fri Feb 03, 2006 7:25 pm
Location: Chattanooga,TN/Bryant,AL

Re: Midland Olympian mic question

Post by Elighting » Fri Jan 26, 2007 2:43 am

jrm5265 wrote:hey guys I have 2 Olympian VHF mobiles and both are doing the same thing.........when you unkey the person your talking to hears what sounds like a metallic clank at end of your tranmission does it on everything Ive got programmed in them so its not ONE repeater etc that its doing it on. Im thinking theres something Ive got set wrong in the programming but Im scared to start changing stuff anybody got an idea what in the programming (ie reverse burst or some kinda mic setting that if set wrong would cause that. Radio sounds good its just that sound at end of transmission thats annoying and sound like metallic clank...........any of you Midlandnites have any ideas?

Thanks
Joe Mobley
East Metro Drug Enforcement
Covington Ga
I have a Olympian myself.I will have to hook it back up and see if mine does it.Does it do it on simplex channels too or just repeater channels?Also,if simplex too,does a PL vs. no PL do any different?My Olympian is also for sale if you'd be interested.Thank you.

Jordan,TCFD,VFD

jrm5265
Posts: 23
Joined: Sat Dec 13, 2003 6:13 pm
Location: Covington Ga

mic

Post by jrm5265 » Fri Jan 26, 2007 9:41 am

Jordan

hey its doing it on both, I havnt checked PL vs No PL Its not like real bad its just annoying TO ME (you how us radio geeks can be) nobody else probably notices it

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest